Download FastCGI Update for Better Performance of PHP on Windows

Posted: Mar 23, 2010  3 comments  

Average Rating

Tags
Developers
IIS News Item
IIS7
PHP
Web App Gallery

Share this Post

Many PHP community applications being used today by Web developers to build Web sites for businesses. IIS has worked hard to make our platform a first class citizen for hosting PHP applications in addition to our ASP.NET integration. The “core” of our PHP application hosting story is FastCGI.

FastCGI is available for IIS6 as a Web download– if you are using IIS6 on Windows Server 2003, you should be running this FastCGI Extension for IIS 5.1 and IIS 6. FastCGI ships as one of the IIS modules “in the box” for Windows Server 2008 and later.

We have released an important update to FastCGI that includes updates to functionality as well as real-time tuning of MaxInstances. Real-time tuning of MaxInstances improves PHP application hosting performance by automatically determining the optimal number of required PHP processes based on the available CPU and memory resources on the server. With this feature, users will not have to manually tune the FastCGI configuration as FastCGI is guaranteed to run at the maximum performance out of the box.

Unrelated to the update but a best practice nevertheless – if you are hosting PHP on IIS, you should (in addition to using the last FastCGI releases) also make sure you are running WinCache. WinCache, which is free and open-sourced on PECL, gives you a set of caches, including byte code cache, user cache, and session cache, that helps accelerate PHP application performance on Windows.

To get the update to FastCGI:

  • If you are using IIS 5.1 (Windows XP) and 6.0 (Windows Server 2003), download FastCGI Extension 1.5 to host your PHP applications.
  • If you are using IIS 7.0 (Vista, Windows Server 2008) or IIS 7.5 (Windows 7, Windows Server 2008 R2), you should apply the update linked to this KB Article. With this update, the IIS FastCGI functionality is consistent from Windows XP (IIS 5.1) up to Windows Server 2008 R2 (IIS 7.5)

Comments

Сгггд

Apr 04 2010 by Alkon

If you are using IIS 7.0 (Vista, Windows Server 2008) or IIS 7.5 (Windows 7, Windows Server 2008 R2), you should apply the update linked to this KB Article (support.microsoft.com). With this update, the IIS FastCGI functionality is consistent from Windows XP (IIS 5.1) up to Windows Server 2008 R2 (IIS 7.5)

This update does not get installed on Windows Server 2008 R2 with IIS 7.5 - says "the update is not applicable to your computer"

how  can I install it?

Apr 25 2010 by Sergey Chervony

Submit a Comment

  • Plain text is accepted.
  • URLs starting with http:// are converted to links.