Friday, March 9, 2007 2:07 PM brian-murphy-booth

How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Note: Although you can get Visual Studio .NET 2003 to work properly on Vista, Microsoft does not support this scenario. "Not supported" doesn't mean "won't work". It just means if you run into any trouble you just can't call the MS support line for assistance with this issue. Microsoft does, however, fully support *running* a .NET v1.1 app on Vista.

Because I support both IIS and ASP.NET here at Microsoft, I find it necessary to have both "Visual Studio .NET 2003" and "Visual Studio 2005" installed. I need to be able effectively troubleshoot issues for whatever product our customers need help with. But like any other tech junky, I like to have the latest-and-greatest OS installed so that I can learn the various features of the OS through day-to-day use. For this reason, I have Windows Vista installed on my primary machine. But, particularly when I was less familiar with the IIS 7.0 UI, getting ASP.NET 1.1 to run on IIS 7.0 was frustrating. Here are some of the errors I encountered while trying to get this setup:


Microsoft Development Environment
Error while trying to run project: Unable to start debugging on the web server. Could not start ASP.NET or ATL Server debugging.
Verify that ASP.NET or ATL Server is correctly installed on the server.

Microsoft Developement Environment
Error while trying to run project: Unable to start debugging on the web server. You do not have permissions to debug the server.
Verify that you are a member of the "Debugger Users" group on the server.

ASP.NET Version Mismatch
Visual Studio .NET has detected that the Web server is running ASP.NET version 1.0. The Web application you are creating or opening can be configured to be compliant with ASP.NET 1.0.
However, the application will not be able to use new features from ASP.NET 1.1.

To set this up properly so the above errors don't occur, follow these steps.

1. Ensure that .NET 1.1 --->SP1<--- or higher is properly installed.

  1. Vista does not include .NET v1.1 by default.
  2. Because .NET 1.1 is not included by default, .NET v1.1 *SP1* is also not included.
  3. Without SP1, W3WP.exe will crash when running an appPool under v1.1 due to DEP
  4. To check this, make sure that c:\Windows\Microsoft.NET\Framework\v1.1.4322\mscorsvr.dll is version 1.1.4322.2032 or higher.
  5. Unless you are 100% sure that SP1 for .NET is installed, you *really* should double-check this.
   

2. Enable IIS 6.0 compatibility

  1. Open Control Panel
  2. Double-click Programs and Features
  3. Expand Internet Information Services
  4. Expand Web Management Tools
  5. Check IIS 6 Management Compatibility
   

3. Register v1.1 with IIS

  1. Open a CMD prompt
  2. Change your directory to c:\Windows\MIcrosoft.net\Framework\v1.1.4322
  3. Run "aspnet_regiis -ir"
  4. "ir" registers v1.1 with IIS but doesn't change any existing script mappings
  5. aspnet_regiis should also create a new AppPool under "Application Pools" called "ASP.NET 1.1" that is configured with the "Classic" pipline, and "Enable32BitAppOnWin64" set to true if a 64-bit OS.
   

4. Make sure IIS permits running ASP.NET.

  1. Open the IIS manager. 
  2. Highlight your Computer Name.
  3. Double-click ISAPI and CGI Restrictions
  4. Select ASP.NET v1.1.4322
  5. Click Allow in the Actions section in the upper right.

 

   

5. Make the new ASP.NET 1.1 appPool the default.

  1. Open the IIS manager
  2. Select the Sites folder.
  3. Under Actions on the upper right, click Set Web Site Defaults...
  4. Change the Application Pool setting to ASP.NET 1.1

 

   

6. **ALTERNATIVE step to 5** - Change the AppPool to ASP.NET 1.1 -->after<-- creating the ASP.NET project instead of making it the default.

  1. Create the v1.1 ASP.NET project via Visual Studio. Attempting to run the project at this point will fail if the 1.1 appPool is not the default.
  2. Open the IIS manager.
  3. Right-click the newly create application directory and choose Advanced Settings
  4. Change the Application Pool to ASP.NET 1.1
  5. Go back to Visual Studio and attempt to run/debug project.
 

Happy coding!!

Comments

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, March 13, 2007 2:34 PM by amcgee

Hi Brian,

Thanks for the post.  I'm also trying to get VS2003 to run on Vista.  I've followed the instructions above (and instructions from a million other websites also!), but am still getting the "You do not have permission to debug the server.  Verify that you are a member of the 'Debugger Users' group on the server."

I am running Vista Home Premium, which does not have the security groups snap-in for the MMC.  Do you know if it is possible to run VS2003 in Vista Home premium?  

Any help is greatly appreciated.  I've spent more hours than I care to count trouble shooting this.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Sunday, April 8, 2007 9:44 AM by citruslime

Brian,

Thanks this really helped. I'd been stuck for hours until I found your blog.  I had to change a few other bits and pieces on my setup which I've documented here http://citruslime.blogspot.com/ in case it helps anyone else.

Neil

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Monday, April 9, 2007 9:43 AM by brian-murphy-booth

Neil,

Thanks for helping to make this all less painful for everybody. I checked out your steps. As far as I can tell the parts that my list is missing are:

1. Disable UAC - Yes I have had UAC disabled for a while. I actually had it disabled prior to ever attempting to install VS2k3 which is probably why I neglected to include this step. An alternative to this would be to right-click Visual Studio in the start menu as do "Run as Administrator".

2. Adjust ISAPI and CGI restrictions - When running aspnet_regiis.exe if one forgets to include the "-enable" switch then IIS will block the ASPNET_ISAPI extension DLL with a 404.2. I'm not sure if perhaps you didn't include that switch? If that switch doesn't work for some reason then manually enabling them like you did is important.

3. Editing Authentication Settings - Yeah... depending on what IIS components you added via "Programs and Features" I can envision that you might not have Integrated Windows Authentication enabled which is required in order to debug ASP.NET applications. I have run into that plenty of times but I didn't include that in my list since the error message usually states exactly what needs to be done.

4. Editing ASP debugging settings - This step would only be required if you want to debug legacy ASP. For a purely ASP.NET application this step would not be necessary. It is also worth noting that you wouldn't need to enable both client-side and server-side debugging. Server-side debugging would suffice since the remote debugging components that come with Visual Studio debug the IIS worker process from the server-side.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Saturday, April 21, 2007 11:26 AM by smcculloch

When you run the SP1 update, did it actually change the version on the file? My install says the SP1 ran OK, but the version is still the same.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Friday, May 11, 2007 9:30 AM by brian-murphy-booth

I installed Vista on a new machine this week and I looked at the version of mscorsvr.dll both before and after installing Visual Studio 2003 SP1 so I could answer your question with 100% certainty. The version in-fact did change. If the version didn't change on your machine after installing SP1 then I'd guess that SP1 got installed another way, perhaps via WindowsUpdate, without you realizing it. If that isn't the case then you likely got a newer DLL through some other hotfix that didn't update the entire framework. In any case, you need to update more than just this single DLL, so if it was updated by something other than SP1, you'd still need to install SP1.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Thursday, May 17, 2007 1:51 PM by ShirleyLL

Thank you so much for this post. I greatly appreciate your work. I was frustrated trying to solve the problem. After trying all other things, VS 2003 still wasn't working for me. I'm happy now that VS 2003 can work in Vista environment and just hope that I won't run into future problems.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Friday, June 8, 2007 4:24 PM by Jim R

Brian, Neil, Thanks a million to you both!! FYI, regarding item #2 above in Brian's April 9 comment, I found it necessary to follow Neil's configuration step in IIS Admin, despite typing the "aspnet_regiis.exe -ir -enable" command a couple of different times. "-enable" didn't seem to enable after all! - Jim

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, June 12, 2007 8:04 PM by bass

I tried all the steps. However, when I create a new 2003 project, the IDE throws "Visual Studio.NET cannot create or open the application. Web site 'http://localhost/mytest' not started on this Web server." Then, a windows popup appears and says "IIS Worker Process stopeed working and was closed. A problem caused the application to stop working correctly. Windows will notify you if a solution is available." I believe I did everything right. ISAPI and CGI is allowed. Ran VS2003 as admin. I am admin and is a member of debugger user group. mscorsvr.dll's version is 1.1.4322.573 (which should be OK). I ran aspnet_regiis -ir -enable successfully after installing vs2003. I'm running Vista Ultimate (upgraded from Vista Home Basic using OEM cd). What have I done or did not do? Thanks.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Wednesday, June 13, 2007 7:23 AM by brian-murphy-booth

Hi Bass,

You version 1.1.4322.573 is actually *NOT* the right version. If you'll note in my original steps, they say that you need 1.1.4322.2032 or higher. Essentially you have version "573" and you need version "2032" or higher. It sounds like you do not have .NET 1.1 SP1 installed yet.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Monday, July 16, 2007 8:43 AM by Damir Colak

I followed the instructions but I cannot even run a .NET 1.1 application on IIS 7 (Vista Business). I keep getting Server Not Available.

This is so frustrating!!! I am developing both .NET 1.1 and 2.0/30 applications and I do have to host both net's on the same machine. :-((

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 17, 2007 1:12 PM by Davide

Hi, I have the same issue of bass. Furthermore, after I have installed the SP1 mscorsvr.dll's version is still the1.1.4322.573! And, I followed all the indicated steps as bass did but I always get the error: "IIS Worker Process stopeed working and was closed. A problem caused the application to stop working correctly. Windows will notify you if a solution is available." Any help / suggestion is very welcome :) Thanks and kind regards

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 17, 2007 1:59 PM by brian-murphy-booth

Damir,

I'd say your most likely problem is that the framework has not been updated correctly with SP1 so that it supports "DEP". Without the ability to handle DEP, the operating system will shut down the process and this looks like a crash. Once an application pool fails to start 5 times within 5 minutes, the "rapid fail protection" kicks in and you'll see "Service Unavailable".

Recommendation: Make sure that "mscorsvr.dll" is version "1.1.4322.2032" or higher. If it isn't, then reinstall .NET v1.1.4322 Service Pack 1.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 17, 2007 2:10 PM by brian-murphy-booth

Hi Davide,

Unfortunately my day-to-day work does not include "setup" issues (we have a special support team for that) so I don't have a mental list of known reasons for what you're seeing. My guess is that there was some setup error that prevented all the DLLs from being properly updated. If I were in your position, I'd first try to find the setup log for the framework and see if any errors or messages in there hint at the root of the problem. Then from there you can take the errors/messages that you find and do an Internet search to see who else has experienced that. A quick search for ".net framework setup log" on the vastly superior "www.Live.net" gives me a list of results that include this one:

Aaron Stebner's WebLog

Thoughts about setup and deployment issues, Windows Media Center, Windows Embedded, the .NET Framework and Visual Studio

blogs.msdn.com/.../479928.aspx

I look up Aaron's name in our GAL ("global address list" in Outlook) and see that he works on the "Deployment Technology" team. In other words, he knows what he is talking about. ;-p. See if he has any info that can get you going in the right direction. I feel confident that once you get the framework updated to all SP1 versions, that you'll be in great shape to develop in VS 2k3.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 17, 2007 3:13 PM by Davide

Hi Brian, 1. I completely uninstalled the Framework 1.1 and Visual Studio 2003. 2. Then I reinstalled VS 2003. 3. hen I installed the SP1 and now the mscorsvr.dll's version is "1.1.4322.2032" while before (i.e. before installing the SP1) the version was "1.1.4322.573". I set the AppPool to "ASP.NET 1.1" for both the Default Web Site and for the application. NOW IT WORKS!!!!!!!!!!!!!! I am so happy, I spent the whole day. I can say that it REALLY works. Thank you Brian for having pointed out that the very important thing is to install the SP1: if the the mscorsvr.dll's version is "1.1.4322.573" IT DOES NOT WORK. Best Regards Davide

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 24, 2007 11:19 AM by Tamara

Brian, Thanks for your help - this has resolved a lot of issues. I ran through your steps and have everything 'almost' working. However, I do have another error but I think it has to do with running .net 2005 and .net 2003 on the same machine. When I attempt to create a new asp application in 2003, I receive the following error: http/1.1 500 Internal Server Error. Any suggestions would be greatly appreciated. Thanks, Tami

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, July 24, 2007 11:26 AM by brian-murphy-booth

The reason for an "Internal Server Error" is almost always stated in the event logs. My guess is that you have .NET v2.0 as the default and VS2k3 is trying to create/run your new project under the wrong framework version setup in IIS. The event logs should tell you the problem though.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, August 21, 2007 2:11 PM by josh

i appreciate the info here...my problem seems to begin prior to these steps, though. i can't install vs2003 web development tools because the installer does not detect frontpage...how did you get around this? i have frontpage installed.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, August 21, 2007 2:28 PM by brian-murphy-booth

I believe there is a button that continues installing even though FrontPage cannot be found. I always skip the FPSE step and everything seems to work fine. You should only need FPSE if you want to connect to the IIS machine remotely. I haven't tried doing that with IIS 7.0 so I don't know how successful that would be.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, August 21, 2007 2:39 PM by josh

wow, thanks for the quick response! i don't get an option to skip...i get a list of all the components i want to install, and the web development components cannot be checked...when i click on them it thinks for a split second and leaves the box unchecked...

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Tuesday, August 21, 2007 3:06 PM by brian-murphy-booth

I looked at my installation and I do not have the Web components installed. Those are only needed if you want to debug remotely but since you cannot install FPSE on Vista (as far as I know), that isn't going to work for you.

# re: How to setup ASP.NET v1.1 (Visual Studio .NET 2003) projects on IIS7 (Vista)

Wednesday, September 12, 2007 3:23 PM by bruce

Brian, thanks for the post/instructions. They have been a time saver for me twice now. I, like others, have noticed that the -enable switch doesn't take and I have to do it manually.